Hadoop平台中各个组件的版本匹配非常重要!不是所有组件都下载最新版本就好,版本不匹配和引发各种问题。

Hadoop和Hbase的匹配关系可以查看Hbase官方文档,搜索‘Hadoop version support matrix’:

http://hbase.apache.org/book.html#basic.prerequisites

Hadoop和Hive的匹配关系查看Hive的下载页面:

http://hive.apache.org/downloads.html

Hbase和Hive的匹配关系可以查看下面网页中的介绍,说的不是很清楚,可以结合Hadoop和Hive的版本匹配关系理解:

https://cwiki.apache.org/confluence/display/Hive/HBaseIntegration

Zookeeper的版本一般来说月新越好,可参照官方文档:

http://hbase.apache.org/book.html#zookeeper

文档中原话:

What version of ZooKeeper should I use?

The newer version, the better. ZooKeeper 3.4.x is required as of HBase 1.0.0

 
--------------------- 
作者:1992zxp 
来源:CSDN 
原文:https://blog.csdn.net/u014333671/article/details/81196341 
版权声明:本文为博主原创文章,转载请附上博文链接!


本文参考链接:https://unclewang.blog.csdn.net/article/details/89486347
评论关闭
IT虾米网

微信公众号号:IT虾米 (左侧二维码扫一扫)欢迎添加!