今天在把本地项目像服务器部署的时候报错java.lang.UnsupportedClassVersionError,我本地用的JDK1.8,服务器是1.7的JDK,所以报这个错误,我又重新在本地安装了JDK1.7,重新编译后上传,问题解决。在这做个记录。

此问题一般出现在高版本JDK向底版本JDK转换的时候。

解决方法:

---------------------------------------------------------------------

1、右键你的项目,Build Path ->configure Build Path 选择需要更换的JDK。

2、右键你的项目,找到Java Compiler 选择适当的JDK。


3、右键你的项目,properties->Java Compiler,选择合适的JDK版本,一般跟你安装的JDK版本相同就OK。

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------

基本上就大工告成了。

发布评论

分享到:

IT虾米网

微信公众号号:IT虾米 (左侧二维码扫一扫)欢迎添加!

mysql 删除数据慢详解
你是第一个吃螃蟹的人
发表评论

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。